GetThings Help - broken now?

Oct 16, 2009 at 7:10 PM

 

 

I am wondering if anyone can help me out. About a week or so ago I wrote some code to call the GetThings method of the xml api. It returned data and everthing was good. Today that same code is not returning data even though there is data in the record.

I get a 0 for response which means okay. So the xml is valid. I have checked and rechecked everything.

I have de-authorized and re-auth.

I have switched records.

I have tried 4 different filters. With and with out date filters, changed types.

I double checked the schema listed to see if there where any changes.

The only thing I can think of that has changed is I also created an Offline rule. However I am using the online method in the java SDK. By setting auth token and record ID. Our online rule has not changed.

 

Here is the xml I am sending to get Weight entries.

<info><group><filter><type-id>3d34d87e-7fc1-4153-800f-f56592cb0d17</type-id></filter><format><section>core</section><xml/></format></group></info>

 

Here is the reply.

<response><status><code>0</code></status><wc:info xmlns:wc="urn:com.microsoft.wc.methods.response.GetThings"><group><filtered>true</filtered></group></wc:info></response>

I am able to GetPersonInfo so I know I have authorization. Anyone have ideas or somewhere else to look?

 

Coordinator
Oct 22, 2009 at 7:19 PM

Hi Ryan,

Does your offline rule include the type you are querying for?  HV will only return types the application is specifically authorized for with the given access mode:  offline/online.

--Rob